Customer login  |   Contact us
Home Company Products Support Purchase
Forum Home » Network Probe

Topic: Could not load native ethernet driver:
Replies: 14   Pages: 1   Last Post: Aug 18, 2004 1:16 PM by: Eivind Pedersen


Back to Topic List Back to Topic List Topics: [ Previous | Next ]
Replies: 14   Pages: 1  
Al Banard
Could not load native ethernet driver:
Posted: Apr 26, 2003 10:16 AM
  Reply

Hi,

I'm getting the following error on startup. I installed libpcap and still got the same message. Any ideas?

Regards

Al

OS: Solaris intel 9
java : 1.4.0_03
Error message:

Starting Network Probe...
Probe startup initialized...
Error: Could not load native ethernet driver: /var/DOWNLOADS/netprobe-0.4/driver/solaris/libdriverif.so

Eivind Pedersen

Posts: 473
From: Oslo, Norway
Registered: Jun 11, 2002
Re: Could not load native ethernet driver:
Posted: Apr 26, 2003 4:11 PM
  Reply

We've received other reports about this problem on Solaris 9. We currently only have a Solaris 8 computer to test on. It should be fixed for the next release.

Al Banard
Re: Could not load native ethernet driver:
Posted: May 9, 2003 3:34 AM
  Reply

Great.

Any estimates on when the next release will be available?

Regards

Al

Eivind Pedersen

Posts: 473
From: Oslo, Norway
Registered: Jun 11, 2002
Re: Could not load native ethernet driver:
Posted: May 9, 2003 10:42 AM
  Reply

0.5 should be available in a few weeks (end of May).

Ron Prague
Re: Could not load native ethernet driver:
Posted: May 29, 2003 8:52 PM
  Reply

I'm having the exact same error on a solaris 8 machine myself.

This is a sunfire v280 and I'm trying to run netwprobe on eri0. Here is the output of uname for this box.

sears# uname -X
System = SunOS
Node = sears
KernelID = Generic_108528-19
Machine = sun4u
NumCPU = 2

Eivind Pedersen

Posts: 473
From: Oslo, Norway
Registered: Jun 11, 2002
Re: Could not load native ethernet driver:
Posted: May 30, 2003 9:47 AM
  Reply

What CPU type is this?

Al Banard
Re: Could not load native ethernet driver:
Posted: Jul 6, 2003 5:02 PM
  Reply

I just downloaded the latest version ( 0.5b1 ) and it now works like a charm Excellent!

OS: Solaris 9 intel

Al

Younes
Re: Could not load native ethernet driver:
Posted: Jul 9, 2004 3:28 PM
  Reply

Hi,

I have exactly the same problem, on startup i get
this message : Could not load native ethernet driver/usr/local/netprobe-1.1.1/driver/freebsd/libdriverif.so

I am runing the version 1.1.1 on FreeBSD 5.2.1 release and also have installed libpcap. Any ideas

Regards

62mkv

Posts: 4
Registered: Aug 17, 2004
Re: Could not load native ethernet driver:
Posted: Aug 17, 2004 4:18 AM
  Reply

Hi !

I'm getting the same message on WinXP Pro machine:

Error: Could not load native ethernet driver: C:\Program Files\Network Probe 1.1.1\driver/windows/driverif.dll

Where is my DNA-code error ??

Eivind Pedersen

Posts: 473
From: Oslo, Norway
Registered: Jun 11, 2002
Re: Could not load native ethernet driver:
Posted: Aug 17, 2004 10:36 AM
  Reply

Which network card is this?

Try this workaround:
1. Run the file "driver-uninstall.exe", located in the network probe directory.
2. Delete the file "netprobe.sys" (if it exists), located under your windows/system32/drivers directory
3. Uninstall Network Probe
4. Reboot your computer
5. Install Network Probe
6. Reboot and start.

62mkv

Posts: 4
Registered: Aug 17, 2004
Re: Could not load native ethernet driver:
Posted: Aug 17, 2004 12:30 PM
  Reply

I've tried your algorithm TRICE (if it's correct to say so, that means three times), the story is just the same !
Launching probe.exe does nothing but probe.log is appended with 182 bytes:

2004/08/17 13:22:14 Probe startup initialized...
2004/08/17 13:22:14 Error: Could not load native ethernet driver: C:\Program Files\Network Probe 1.1.1\driver/windows/driverif.dll

I can say that windows/system32/drivers/NetProbe.sys exists and has a size of 5365 bytes, and registry branch
HKLM\SYSTEM\CurrentControlSet\Services\NetProbe also exists, with 4 subkeys.

Th NIC name is
"Realtek RTL8139 Family PCI Fast Ethernet NIC #2"

If anyone can somehow help me, I'd be quite happy to know !

Thanks !

Eivind Pedersen

Posts: 473
From: Oslo, Norway
Registered: Jun 11, 2002
Re: Could not load native ethernet driver:
Posted: Aug 17, 2004 1:29 PM
  Reply

Start the probe from command line, with the "-verbose" parameter to see more detailed error message:
(first cd to program files\network probe 1.1.1)
java -jar Probe.jar -verbose

And give me the output of this.

62mkv

Posts: 4
Registered: Aug 17, 2004
Re: Could not load native ethernet driver:
Posted: Aug 18, 2004 10:53 AM
  Reply

Sorry for my lamership, but this command gives :

"java" is not recognized as an internal or external command, operable program or batch file

May be that's the point of problem ?

where can I get that "java.exe" for WinXP ?

62mkv

Posts: 4
Registered: Aug 17, 2004
Re: Could not load native ethernet driver:
Posted: Aug 18, 2004 11:11 AM
  Reply

AHA ! I guessed what was wrong with java ! I need to use jview instead !

Now this is the command line:

jview /cp Probe.jar com.objectplanet.probe.server.Probe -verbose

and this is the answer :

2004/08/18 12:09:39 Probe startup initialized...
2004/08/18 12:09:39 EthernetDriver (constructor): C:\Program Files\Network Probe 1.1.1\driver/windows/driverif.dll cannot load because RNIGetCompatibleVersion export not found (new behavior.)
2004/08/18 12:09:39 Error: Could not load native ethernet driver: C:\Program Files\Network Probe 1.1.1\driver/windows/driverif.dll

Eivind Pedersen

Posts: 473
From: Oslo, Norway
Registered: Jun 11, 2002
Re: Could not load native ethernet driver:
Posted: Aug 18, 2004 1:16 PM
  Reply

For some reason your version of Microsoft's JVM is not able to load the native driver. We cannot reproduce the problem, neither have we received other reports about this.

Download and install Sun's Java from http://www.java.com to get rid of the problem.



© 1998-2019 ObjectPlanet, Inc. Øvre Slottsgate 5, 0157 Oslo, Norway Tel (+47) 2233 3360 | Fax (+47) 2233 3361