Customer login  |   Contact us
Home Company Products Support Purchase
Forum Home » Survey software » Opinio

Topic: HTML & PDF Report error
Replies: 3   Pages: 1   Last Post: Feb 21, 2008 1:10 PM by: Eivind Pedersen


Back to Topic List Back to Topic List Topics: [ Previous | Next ]
Replies: 3   Pages: 1  
luckyduck

Posts: 3
Registered: Feb 13, 2008
HTML & PDF Report error
Posted: Feb 13, 2008 11:54 AM
  Reply

Hi,

I'm having problems using the html & pdf report functions. If I click on a link which belongs to a "summary report", I always get "requested page not found". I looked around on the filesystem, and found the files which should be served via http (the reports get generated, but not displayed). If I then try to access them directly, I get:



Es ist ein schwerer Fehler aufgetreten. Bitte wenden Sie sich an den Administrator!

Details ->

Stack trace:
java.lang.IllegalStateException at org.apache.catalina.connector.ResponseFacade.sendError(ResponseFacade.java:405) at org.apache.catalina.servlets.DefaultServlet.serveResource(DefaultServlet.java:727) at org.apache.catalina.servlets.DefaultServlet.doGet(DefaultServlet.java:376) at javax.servlet.http.HttpServlet.service(HttpServlet.java:690) at javax.servlet.http.HttpServlet.service(HttpServlet.java:803) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188) at com.objectplanet.survey.view.ReportFileFilter.doFilter(KFQA:69) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174) at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:433) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151) at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200) at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283) at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773) at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703) at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895) at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685) at java.lang.Thread.run(Thread.java:595)

Any hints? I'm running version 6.0.4 on SuSE 10.2 (Tomcat 5.5, jdk 1.5).

luckyduck

Posts: 3
Registered: Feb 13, 2008
Re: HTML & PDF Report error
Posted: Feb 13, 2008 11:57 AM
  Reply

Interesing is, if i select "comment report" (dont know if this is the correct translation, in german it's called "kommentar bericht"), everything works fine.

luckyduck

Posts: 3
Registered: Feb 13, 2008
Re: HTML & PDF Report error
Posted: Feb 15, 2008 6:02 PM
  Reply

What i can tell you so far, it has to be related to charset problems in some kind of way. The files & dirs are named for example "\?berblicksBericht_08_01_30_14_55_44_572.html_files" or \?berblicksBericht_08_01_30_14_55_44_572.html". But the log tells me:

15 Feb 2008 18:00:12 -- INFO -- default: DefaultServlet.serveResource: Serving resource '/reports/files/6/7/html/‹berblicksBericht_08_01_30_14_55_44_572.html' headers and data

The DB we're using is the default Apache derby (nothing modified at all). Is there anybody out there with an idea? We're running Suse 10.3 .

Eivind Pedersen

Posts: 472
From: Oslo, Norway
Registered: Jun 11, 2002
Re: HTML & PDF Report error
Posted: Feb 21, 2008 1:10 PM
  Reply

I think the problem must be on the file-system level. I just tried to reproduce the problem on a Linux (Fedora) installation, using German as language, without any problems. The file names are also showing correct (‹, not \?). So I think you need to set correct encoding (UTF-8?) or language on your Suse.

Another work-around is to use English as language for the user (in Opinio). The reports will then be named "Summaryreport_xxx" instead of "‹berblicksBericht".

I also believe you can edit the language file (ApplicationResources_de.properties), located under the opinio/WEB-INF/classes/i18n directory, search for the line starting with "report.name.summary=" and replace "‹berblicks-Bericht" with "Ueberblicks-Bericht" for example.



© 1998-2019 ObjectPlanet, Inc. Øvre Slottsgate 5, 0157 Oslo, Norway Tel (+47) 2233 3360 | Fax (+47) 2233 3361