Customer login  |   Contact us
Home Company Products Support Purchase
Forum Home » Network Probe

Topic: Java Error with linux driver
Replies: 16   Pages: 2   Last Post: Jan 22, 2010 4:21 PM by: Masonic


Back to Topic List Back to Topic List Topics: [ Previous | Next ]
Replies: 16   Pages: 2   [ 1 2 | Next ]
11up

Posts: 4
Registered: Feb 9, 2006
Java Error with linux driver
Posted: Feb 9, 2006 11:27 AM
  Reply

Hi guys when trying to run network probe I get the following error:

Starting Network Probe...
Exception in thread "main" java.lang.UnsatisfiedLinkError: Error: Could not load native ethernet driver: /opt/netprobe/driver/linux/libdriverif.so
at com.objectplanet.probe.server.Probe.main(KFQA)

I've tried with jre-1_5_0_06 and j2re-1_4_1_07

Is there a newer version of the file "libdriverif.so"?

Eivind Pedersen

Posts: 473
From: Oslo, Norway
Registered: Jun 11, 2002
Re: Java Error with linux driver
Posted: Feb 9, 2006 2:48 PM
  Reply

Which linux distribution?

11up

Posts: 4
Registered: Feb 9, 2006
Re: Java Error with linux driver
Posted: Feb 9, 2006 6:45 PM
  Reply

Contribs SME Server 6.0. Which is basicaly redhat 7.x I think.

phowardcom

Posts: 1
Registered: Mar 30, 2006
Re: Java Error with linux driver
Posted: Mar 30, 2006 11:42 AM
  Reply

I am getting exectly the same problem trying to load this onto SME server too.

Any ideas anyone?

Eivind Pedersen

Posts: 473
From: Oslo, Norway
Registered: Jun 11, 2002
Re: Java Error with linux driver
Posted: Mar 30, 2006 1:20 PM
  Reply

We are looking into this problem now, and I will make a new libdriverif.so available for download once it has been fixed.

Eivind Pedersen,
Programmer, ObjectPlanet Inc.

Eivind Pedersen

Posts: 473
From: Oslo, Norway
Registered: Jun 11, 2002
Re: Java Error with linux driver
Posted: Mar 31, 2006 3:17 PM
  Reply
libdriverif.so (136,9 K)

I believe we have fixed it now. The patched libdriverif.so is attached, copy it to the netprobe/driver/linux directory.

Eivind Pedersen
Programmer, ObjectPlanet Inc.

kasper

Posts: 1
Registered: Apr 25, 2006
Re: Java Error with linux driver
Posted: Apr 25, 2006 5:32 PM
  Reply

the patched libdriverif.so is a no go for me on Redhat 7.3 ... any ideas?
Error: Could not load native ethernet driver: /usr/share/netprobe/driver/linux/libdriverif.so


jave 1.4.2_11
redhat 7.3


Message was edited by: kasper

pogden100b

Posts: 2
From: Berkeley, CA, USA
Registered: May 8, 2006
Re: Java Error with linux driver
Posted: May 8, 2006 9:59 PM
  Reply

We are trying to evaluate version 1.2.2 and are experiencing the same problem:

Starting Network Probe...
2006/05/08 13:02:13 Error: Could not load native ethernet driver: /usr/local/netprobe/driver/linux/libdriverif.so

Downloaded the patched libdriverif.so from this thread, still no luck.

linux distro = redhat 7.3
kernal version = 2.4.18-3
java version = 1.4.2_08


Message was edited by: pogden100b


pogden100b

Posts: 2
From: Berkeley, CA, USA
Registered: May 8, 2006
Re: Java Error with linux driver
Posted: May 8, 2006 10:11 PM
  Reply

Was able to get it ( ver 1.2.2 ) running on a later kernal:

linux distro = redhat fc3
kernal version = Linux 2.6.9-1.667smp
java version 1.4.2_08

Maelvon

Posts: 3
Registered: Dec 6, 2006
Re: Java Error with linux driver
Posted: Dec 6, 2006 3:37 PM
  Reply

Not working on a SME 6.0.1-01
# uname -rms
Linux 2.4.20-18.7smp i686
#./netprobe start eth0
Error: Could not load native ethernet driver: /root/tmp/netprobe/netprobe/driver/linux/libdriverif.so

Is this the version of the kernel which is at the problem's origin?

Thanks,

Maelvon


Message was edited by: Maelvon

Eivind Pedersen

Posts: 473
From: Oslo, Norway
Registered: Jun 11, 2002
Re: Java Error with linux driver
Posted: Dec 11, 2006 4:48 PM
  Reply

Have you tried the 2.0 beta version? We compiled new drivers for this version, using kernel 2.4.21.

Are you able to try with kernel 2.4.21 or above?

Best regards,
Eivind Pedersen
ObjectPlanet, Inc.

Maelvon

Posts: 3
Registered: Dec 6, 2006
Re: Java Error with linux driver
Posted: Dec 12, 2006 6:31 PM
  Reply

I'm on a SME 6.0.1-01 and It was based on redhat7.3. The kernel installed is 2.4.20-18.7 and the last version I've found is 2.4.20-46.7.legacy for a rh7.3.

I don't think I can upgrade to a 2.4.21.x, as far as I know.

I'm thinking to upgrade from SME 6.x to the 7.x which is based on Fedora, the kernel will be higher I suppose...

I've tried the 2.0b2 beta with 2.4.20-18 kernel and it's the same thing :
Error: Could not load native ethernet driver: /root/tmp/netprobe/netprobe/driver/linux/libdriverif.so

Thanks for the answer.

Maelvon

Maelvon

Posts: 3
Registered: Dec 6, 2006
Re: Java Error with linux driver
Posted: Dec 16, 2006 3:34 PM
  Reply

# uname -rms
Linux 2.6.9-42.0.2.ELsmp i686

It work's with the upgraded SME 7 version, the kernel is now 2.6.9-x

Bye !

Maelvon

totophe

Posts: 1
From: Brussels
Registered: Apr 8, 2009
Re: Java Error with linux driver
Posted: Apr 8, 2009 2:22 PM
  Reply

Hi guys,

I have the same problem to run netprobe.

I'm on Ubuntu 8.04 and Java 6.

Can you help me ?

daliusm

Posts: 1
From: Lithuania
Registered: Sep 21, 2009
Re: Java Error with linux driver
Posted: Sep 21, 2009 4:23 PM
  Reply

Hello,
same problem with Ubuntu 8.04 LTS/jre6.16.

I built gateway as vmware appliance, which is also Ubuntu 8.04/jre6.16. Network probe runs on it but here is another problem - network terminating time to time. But this seams happens with all network monitoring soft packages which runs on vmware appliance.



© 1998-2019 ObjectPlanet, Inc. Øvre Slottsgate 5, 0157 Oslo, Norway Tel (+47) 2233 3360 | Fax (+47) 2233 3361