Customer login  |   Contact us
Home Company Products Support Purchase
Forum Home » Network Probe

Topic: Task bar icon dissappeard....
Replies: 4   Pages: 1   Last Post: Mar 24, 2004 3:07 PM by: mtbcyclist


Back to Topic List Back to Topic List
Replies: 4   Pages: 1  
mtbcyclist

Posts: 13
From: Raleigh NC
Registered: Mar 23, 2004
Task bar icon dissappeard....
Posted: Mar 23, 2004 7:31 PM
  Reply

I am running Network Probe as a service. I recently had to change my user account in windows. So what I did was create a new account for myself, and copy my old profile though windows to my new account so I could retain all of my old account settings. Having to do user account naming convention to integrate our passwords/user accounts for an AS400/Windows integrated domain controler project.

Anyways after I did that the Task bar icon has dissappeared. Network probe is still running as a service in the background. Now the only way I can start the network probe client is to open a Internet Exporer session and type in the web address for the client. If I log into the PC with a different account, the icon shows up. It has something to do with the profile I am using. For what its worth, when I have perfomed profile copying I have had small issues similar to this with other types of software.

Kind of strange? Have any solutions to this?

Eivind Pedersen

Posts: 473
From: Oslo, Norway
Registered: Jun 11, 2002
Re: Task bar icon dissappeard....
Posted: Mar 24, 2004 1:21 PM
  Reply

The account must have administrator privileges.
And the registry entry starting the Network Probe service app is under
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

It should have the entry "Network Probe", with value "javaw -cp "C:\Program Files\Network Probe 1.1b1./Probe.jar" com.objectplanet.probe.windows.systray.gui.LogWindow -home "C:\Program Files\Network Probe 1.1b1" -systray"

If you don't want to mess with the registry, uninstall the probe service by typing "probesvc -r" from your Network Probe directory. Then start Network Probe (from your new account), and choose to run as a service. Then reboot.

mtbcyclist

Posts: 13
From: Raleigh NC
Registered: Mar 23, 2004
Re: Task bar icon dissappeard....
Posted: Mar 24, 2004 2:55 PM
  Reply

I did both items what you had said, and it did not fix it. I did kill the service logged in as an admin. I then logged in as my new account (no admin privedges) and clicked the box "run as a service". Next I rebooted the machine logged in with my new non-admin account, and the servcie did not start or was no where to be found. Its like I never even went though the steps to run as a service. Basically when I reboot, it is not saving the settings to "run as a service".

So next I decided to do all of this in my admin account and it worked. Now I logged back in with my non-admin account, and the service is running but the icon in the task bar is still not there. If I change my non-admin account to an accout with admin privledges, and log out and log in then the icon appears. For what ever reason its like the icon in the taskbar is depenedent on if my current user accout is an admin or regular user. Weird. Admin rights, it works, regular user rights, it does not work.

Things that make you go hmmmmm.... Any other suggestions?

Eivind Pedersen

Posts: 473
From: Oslo, Norway
Registered: Jun 11, 2002
Re: Task bar icon dissappeard....
Posted: Mar 24, 2004 3:02 PM
  Reply

As I said, administrator privilege is required to run the systray application. Otherwise we would have a security issue (a user could start/stop the probe from the systray).

mtbcyclist

Posts: 13
From: Raleigh NC
Registered: Mar 23, 2004
Re: Task bar icon dissappeard....
Posted: Mar 24, 2004 3:07 PM
  Reply

Ahhhh... OK. I misunderstood your email. I thought that your email meant that you needed admin privledges to make the changes (which is also true).

Sorry, and thanks for your help. Never realized it as a security issue, but you are exactly right!


Thanks again!


Message was edited by: mtbcyclist




© 1998-2019 ObjectPlanet, Inc. Øvre Slottsgate 5, 0157 Oslo, Norway Tel (+47) 2233 3360 | Fax (+47) 2233 3361